BNB Smart Chain Mainnet , Degraded Archive RPC Performance

Incident Report for Quicknode

Resolved

This incident has been resolved. Archive RPC methods are operating normally across all regions. We will continue to monitor for any recurrence.
Posted Aug 20, 2026 - 15:15 UTC

Monitoring

Performance on archive RPC methods has improved significantly. We are continuing to monitor the situation.
Posted Aug 20, 2026 - 13:10 UTC

Investigating

BNB Smart Chain mainnet is experiencing degraded performance on archive RPC methods. Some requests for historical data (trace, debug, and historical state lookups) may see increased latency or intermittent 503 errors. We are monitoring the situation and working on a resolution.
Posted Aug 20, 2026 - 10:52 UTC
This incident affected: BNB Smart Chain (BSC) (Mainnet — JSON-RPC API, Mainnet — WebSocket API, Mainnet — Webhooks, Mainnet — Streams).