Cosmos Mainnet Network Stalled at Block 32,878,318

Incident Report for Quicknode

Resolved

This incident has been resolved with direct communication with Cosmos Labs. Please see the Cosmos Lab's post for additional information on their binary package used to resolve this incident: https://x.com/cosmoslabs_io/status/2097986609433960711
Posted Sep 12, 2026 - 00:24 UTC

Monitoring

Our nodes have recovered and are back at the chain tip. We are continuing to monitor the situation and will provide further updates as needed.
Posted Sep 09, 2026 - 14:26 UTC

Identified

The underlying issue has been identified. We are working with the Foundation to restore normal block progression. Further updates will be provided as the situation develops.
Posted Sep 09, 2026 - 05:48 UTC

Investigating

Cosmos Mainnet appears to have stalled at block 32,878,318 - The Quicknode team is investigating and will update with more information once it is available.
Posted Sep 08, 2026 - 18:12 UTC
This incident affected: Cosmos (Cosmos Mainnet — REST API).