Polygon Amoy - Scheduled Stress Test

Incident Report for Quicknode

Identified

The Polygon Foundation is currently running a stress test on the Amoy network. Users may experience elevated latencies, 503 responses and degraded performance during the duration of the stress test. Our team is working to resolve the degradation and we will follow up on this page with further updates.
Posted Aug 20, 2026 - 15:51 UTC

Investigating

The Polygon Foundation is running a stress test on the Amoy network at 15:00 UTC. Users may experience elevated latencies and degraded performance during the duration of the stress test. We will keep this page updated as the test progresses.
Posted Aug 20, 2026 - 14:38 UTC
This incident affects: Polygon (Amoy — JSON-RPC API, Amoy — Websockets API, Amoy — Webhooks, Amoy — Streams).